martes, 27 de mayo de 2014

El promedio ponderado y la administración de Inventarios

El mes pasado me contrataron de una empresa para que les desarrolle una aplicación con Visual Basic for application en Excel, que administre el inventario. Ante esta situación, utilice el  Promedio Ponderado para poder calcular el costo del inventario.
Antes de continuar es importante tener claro que significa Promedio Ponderado.

Para ello, todos sabemos que el Promedio es la suma de varias cantidades, divididas entre el número de valores.

Por ejemplo:

En este caso hemos utilizado la función PROMEDIO

Ahora, si deseamos hallar el Promedio Ponderado, vamos a usar la función SUMAPRODUCTO

Antes de aplicar dicha función, vamos a hallar la ponderación de cada linea. Esto se obtiene dividiendo la cantidad de la linea entre la cantidad total. Por ello en la celda D2, hemos colocado la siguiente formula:

=B2/SUMA($B$2:$B$5)


Finalmente procedemos a calcular el Promedio Ponderado utilizando la función SUMAPRODUCTO, como vemos a continuación:

=SUMAPRODUCTO( C2:C5 D2:D5 )

En donde el primer rango es el rango de precios, y el segundo rango es el de el porcentaje que representa cada precio.

Por cierto, les comento que la aplicación de administración de inventarios quedo "CHIVISIMA" (como dirían mis amigos ticos). Ya está 100% funcional en El Salvador... aquí una imagen (por si desean contratarme)



Espero que le sirva