martes, 7 de agosto de 2018

¿Cómo validar valores repetidos en Excel? ... Utilizando Validación de datos


Muchas veces nos encontramos con tablas que tienen valores repetidos o duplicados. Y la mejor forma de combatirlos es evitar el ingreso de valores duplicados. Por ello, vamos a ver algunas reglas de validación que nos pueden ser muy útiles para evitar valores repetidos.

El proceso es muy similar al que ya hemos visto antes, solamente hay que cambiar las formulas que se indican a continuación.

La validación de datos permite limitar el tipo de datos que pueden escribirse en una celda. Para ello debemos seleccionar la celda o rango de celda donde deseamos aplicar la validación, para ello vamos a la Cinta de Opciones, Etiqueta Datos, Grupo Herramienta de datos, y seleccionamos Validación de datos



Luego en la ventana que nos aparece, hacemos lo siguiente:
  • Ir a la etiqueta Configuración.
  • En la opción Permitir, seleccionamos Personalizada.
  • En la casilla de formula, escribimos los casos que indicaremos a continuación (considerando A1).



EVITAR REPETIDOS ENTRE CELDAS

=B1<>A1

EVITAR REPETIDOS EN COLUMNA

=CONTAR.SI($A$2:$A$10;A2)=1

EVITAR REPETIDOS EN FILA

=CONTAR.SI($A$2:$F$2;A2)=1

EVITAR REPETIDOS ENTRE COLUMNAS

=CONTAR.SI($A$2:$A$9;B2)<>1

EVITAR REPETIDOS ENTRE COLUMNAS SEGÚN CELDA

=CONTAR.SI(A2;B2:B9)<>1

EVITAR REPETIDOS EN RANGO

=CONTAR.SI($A$1;$D$9:$A$2)=1