miércoles, 18 de julio de 2018

¿Cómo validar textos en Excel? ... Utilizando Validación de datos

Acabo de encontrar una página con mas de 40 ejemplos de como validar datos en Excel, sin embargo, voy a publicar segmentando estos ejemplos por tipo de datos, es decir por textos, por fechas, etc.
Como diría el dermatólogo: "Vamos directo al grano"

La validación de datos permite limitar el tipo de datos que pueden escribirse en una celda. Para ello debemos seleccionar la celda o rango de celda donde deseamos aplicar la validación, para ello vamos a la Cinta de Opciones, Etiqueta Datos, Grupo Herramienta de datos, y seleccionamos Validación de datos



Luego en la ventana que nos aparece, hacemos lo siguiente:
  • Ir a la etiqueta Configuración.
  • En la opción Permitir, seleccionamos Personalizada.
  • En la casilla de formula, escribimos los casos que indicaremos a continuación (considerando A1).


Para escribir solo texto

=ESTEXTO (A1)

Para escribir solo en texto en mayúscula

=IGUAL(A1;MAYUSC(A1))

Para escribir solo en texto en minúscula

=IGUAL(A1;MINUSC(A1))

Para escribir la primera letra de cada palabra en mayúscula y el resto en minúscula

=IGUAL(A1;NOMPROPIO(A1))

Para escribir solo caracteres de la A-Z, a-z.

=ESNUMERO(SUMAPRODUCTO(HALLAR(EXTRAE(A1;FILA(INDIRECTO(“1:”&
LARGO(A1)));1);”abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ”)))

Para escribir un texto que comienza con AA-.

=CONTAR.SI(A1;"aa-*")

Para escribir un texto que comienza con AA-. (MAYÚSCULA).

=IGUAL(IZQUIERDA(A1;3);"AA-")

Para escribir un texto que finaliza con AA-.

=IGUAL(DERECHA(A1;3);"AA-")

Para escribir un texto que incluya AA.

=CONTAR.SI(A1;”*aa*”)

Para escribir un texto cuyo 5o caracter es una L.

=IGUAL(“L”;EXTRAE(C7;5;1)

Para evitar espacios en una celda

=A1=SUSTITUIR(A1;” “;””)

=LARGO(A1)=LARGO(SUSTITUIR(A1;” “;””))

=A1=ESPACIOS(A1)

Para validar una cuenta de E-mail

=O(ESNUMERO(COINCIDIR(“*@*.???”;A1;0));ESNUMERO(COINCIDIR(“*@*.??”;A1;0)))

Para evitar 2 o más @.

=SUMA(LARGO(A1)-LARGO(SUSTITUIR(A1;”@”;””)))=1

Para escribir solo fórmulas

=ESFORMULA(A1)

Espero que les sirva.

Ing. Enrique Neciosup Morales