lunes, 29 de octubre de 2012

Combinar datos de filas duplicadas en Excel


Hoy me encontré con esta pregunta en Internet, en el cual de una tabla de datos inicial (tabla de la izquierda) deseo crear un resumen en donde pueda combinar (o mejor dicho concatenar) los datos de las filas duplicadas. (tabla de la derecha)

La respuesta a esta situación también se encuentra en Internet, pero lo venden a $ 29.95, precio que personalmente me parece un robo; es por eso que decidí darle unos minutos de mi tiempo a esta pregunta, por si alguno de ustedes se encuentra en una situación similar...

Generé la siguiente tabla con datos ficticios:


El primer paso a realizar es ordenarlo por código, para luego crear la siguiente formula en la columna D:
=SI( Y(A1=A2;C1<>C2) D1&", "&C2 C2 )

La formula quiere indicar que SI la celda A1 es igual a A2 Y la celda C1 es diferente a C2; entonces uniremos el valor de D1 con C2 (separados por coma); sino que me devuelva el valor de C2.


Luego en la columna E creo un campo con el nombre Verificar, en cual coloco la siguiente formula:
=SI( A2=A3 ; "Eliminar" ; "No eliminar" ) 

Estamos utilizando la función SI, la cual nos esta indicando si la celda A2 es igual a A3; entonces que me devuelva el mensaje "Eliminar"; y si no son iguales que me devuelva el mensaje "No eliminar"...



Ahora copiamos y pegamos como valores las celdas de la columna D y E, para luego Filtrar la columna Verificar por los valores a eliminar



Por ultimo elimino las filas que se muestran y las columnas C y E, para obtener el siguiente resultado:



Cualquier consulta, no dude en indicármela y con gusto la atenderé.

Ing. Enrique Neciosup Morales
enrique@expertosenexcelpc.com 
Síguenos en Facebook